MSC Disruption

Incident Report for Vizion

Resolved

MSC is fully operational as of Friday Jun 26th.
Posted Jun 29, 2026 - 11:49 PDT

Monitoring

A fix has been implemented and connection to the carrier has been restored.
Posted Jun 26, 2026 - 10:00 PDT

Investigating

We are currently investigating this issue.
Posted Jun 24, 2026 - 12:31 PDT
This incident affected: Ocean Carrier Connections (MSC).